As of now, I am happy user of 9.1devel version of PostgreSQL: =$ psql -c 'select version()' ...